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		The article explains how to export different PDF files to Excel manually or using free online converters, and how to choose the conversion method best suited for a given file type.

The PDF format that allows presenting documents independently of the user's software, hardware or operating system has already become a de facto standard for electronic file exchange.

If you ask someone for some information, and if that someone is a well-meaning person, there's a good chance that you will get a neatly formatted PDF document with the requested data accompanied by tables, graphics and diagrams for your perusal.

However, PDF files are purposed solely for viewing data and not for manipulating it. So, if your task implies re-arranging the data for further analysis, you will have to either bug the correspondent for another file, or convert the PDF document into some editable format. And this tutorial will teach you how to import a file from PDF to Excel in just a few minutes.


	Choose the right method depending on the PDF file type
	Convert a PDF file to Excel through Word
	Online PDF to Excel converters
	Desktop software to convert PDF to Excel
	Convert an image (scanned) PDF into Excel






Choosing the right method for PDF to Excel conversion

Choosing the proper method for converting a certain PDF to Excel depends on how this or that PDF document was created. Someone may think that all PDF files are essentially the same. But in fact, they are not.

If a PDF document was obtained from an electronic source such as a Word document or an Excel spreadsheet, it contains text characters that can be read and interpreted by Microsoft Office applications as well as by various PDF converters. If you want to import such PDF to Excel, you can do this manually or use some third-party PDF to Excel converters or Adobe software.

A PDF file can also be created by scanning some paper document or by using some other device that takes an image of the document and then stores it as a PDF file. In this case, a PDF is just a static picture, and in order to export it into an editable Excel sheet, special OCR software is required.




Convert PDF to Excel through Word

For occasional PDF to Excel conversions, you may not want to bother searching for a special tool and do the job with what you have at hand, i.e. any PDF viewer, Microsoft Excel and Word. Please remember that this method works only for PDF documents created electronically.

In the nutshell, the conversion involves exporting the data first into a Word document first, and then copying it to an Excel workbook. The detailed steps follow below.


1. Copy the source table from a PDF file.

Open the PDF file in Adobe Reader, or any other PDF viewer, select the table you want to convert to Excel and press Ctrl + C to copy it to the clipboard.






2. Paste the table into a Word document.

Open a new Word document and paste the copied data by pressing Ctrl + V. You will get something similar to this:






3. Convert the copied data into a table (optional).

If your PDF data was pasted into a Word document as a properly structured table, like you see in the screenshot above, skip this step.

If thedatawas inserted into Word as text rather than a table, you can convert it to a table in one of the following ways:

	Fast way. Press Ctrl + A to select all the data, switch to the Insert tab and click Table > Inset table...

This should convert the pasted data into a poorly formatted but correctly structured Word table.
	Longer way. If the fast way did not produce the expected result, select all the data and click Insert > Table >Convert Text to Table… The dialogue box will appear, and you select Other under Separate Text at, click in the little box next to it, delete what is there, type in a space, and press OK.






4. Copy the table from Word to Excel.

In the Microsoft Word document, select all the data (Ctrl + A), open a new Excel sheet, select any cell (this will be the left-most cell of the table) and press Ctrl + V to paste in the data copied from Word.




5. Format and edit the Excel table.

If you are converting a small and simple table, this step may not be necessary. However, from my experience, it's a very rare case when the data exported from PDF to Excel manually does not require any further manipulation. Most often, you would need to do some adjustments to restore the original table's layout and format. For example, you may need to delete some blank rows or add / remove individual cells to ensure the columns are correctly aligned.

Advantages: The main "Pro" of this approach is that no special tools are required, only a PDF viewer, Microsoft Word and Excel.

Drawback: The original formatting is lost,further manipulations with converted data are required.





PDF to Excel converters online

If you have a big and sophisticatedly formatted PDF file, it may be quite tiresome to restore the format and structure of each table manually. In this case, it makes sense to commission the task to some PDF to Excel online converter.

Although there exists a great variety of online Excel to PDF converters, the principle of operation is basically the same. You upload a PDF file to the web-site, specify your email address and find an Excel workbook in your inbox as soon as the conversion process is complete. Some converters do not even require an email address and allow downloading or opening the converted Excel file directly from the web-site.

Most of online PDF to Excel converters have a daily or monthly limit to the number of files that you can convert for free. Some services also set a limit to the file size. You can usually remove these limitations by signing up for a paid subscription.

Now we are going to toy with a few popular PDF to Excel online converters and see which one produces the best results.

And here is the original PDF file to be turned into a workable Excel spreadsheet:




Nitro Cloud - free PDF to Excel online converter

This is one of the most popular online services for converting PDF files to Microsoft Excel, Word and PowerPoint. Nitro Cloud can also perform conversions in the opposite direction, i.e. from PowerPoint, Word or Excel to PDF, and we have already reviewed it in the previous article - Converting Excel to PDF.

If you have any experience with online services, you have probably noticed that they are designed in such a way as to make a conversion as easy and intuitive for the user as possible. The Nitro PDF converter is not an exception. You only need to choose the source file, specify the file formats, enter your email address and click "Convert Now".



Result: The converted Excel file will arrive into your inbox in a couple of minutes. For example, this is how my sheet looks like:



If you compare it with the original PDF file, you'll notice that a beautiful heading is gone, formatting is essentially distorted, but in general you have something to work with.

Besides the online service, Nitro has a desktop version of the PDF to Excel converter, and a 14-day trial is available at www.pdftoexcelonline.com.




Free PDF Converter

The online PDF converter available at www.freepdfconvert.com also performs various conversion types, including PDF to Excel, PDF to Word, PDF to PowerPoint, PDF to Image and vice versa.

With this converter, you can either get the output Excel file by email or download it from the web-site.



Result: When it comes to the result, well... that was something outrageous!



Only 3 lines from the original PDF document survived the conversion, and naturally those remains were sent to the Recycle Bin straight away. It's fair to say that this PDF to Excel converter coped much better with simpler tables, but given its limitations - 10 conversions per month and 30-minute lag to convert another file - this wouldn't be my choice anyway.




Cometdocs PDF to Excel online converter

As well as Nitro, Cometdocs provides the desktop and online versions of their PDF converter, both are available at www.pdftoexcel.org.

Their free service will make you wait for 30 minutes even to convert the first document, which is of course disappointing, but tolerable if you are going to get a perfect result in the end.

Result: I wouldn't say the output Excel file is perfect. The formatting is only a vague reminiscence of the original PDF document, a couple of extra blank cells appear, nevertheless, the main goal is reached - the PDF data was turned into an editable Excel spreadsheet.






One more online PDF Converter

As most of online services, the converter with a clear and unpretentious name PDFConverter.com can help you import the contents of your PDF files into Excel, Word and PowerPoint. After you select the desired output format, you are to perform the usual 3 steps - select a file to convert, type your email address and click the Start button:



A paid desktop version of this PDF converter is also available, and you can download a 15-day trial here.

Result: Fairly good. In fact, the Excel sheet they emailed to me was exactly the same as Cometdocs', probably both services use one and the same conversion algorithm.

If none of the above online PDF to Excel converters has met your requirements in full, you can find plenty more on the web.





Desktop software to convert PDF to Excel

If you have to perform PDF to Excel conversions on a regular basis and if quick and accurate transfers of native PDF documents into formatted Excel worksheets is what you are after, you may consider investing in professional desktop software.


Exporting PDF to Excel using Adobe Acrobat XI Pro

To begin with, the Adobe Acrobat Pro subscription is pretty expensive (around $25 per month). Though, the price is probably justifies since it includes a wealth of features that allow all possible manipulations with PDF files, including the ability to import PDF into Excel.

The conversion process is very quick and straightforward:

	Open a PDF file in Acrobat XI.
	Click Tools > Content Editing > Export File to... > Microsoft Excel Workbook.

  
  If you prefer working with the main menu, click File > Save as other... > Spreadsheet > Microsoft Excel Workbook. If someone still uses Excel 2003, select XML Spreadsheet 2003 instead.

	Give a name to the Excel file and choose the destination folder.
If you have an Adobe account, you can save the converted .xlsx file to it by clicking a little black arrow next to "Save to Online account" at the bottom of the window.

After selecting the folder, either click the Save button to finish the conversion or Settings for more options.



	 Configure the settings.
In the "Save As XLSX Settings" dialog window, you have the following choices:

	Convert the PDF file as a single worksheet or export each page to a separate sheet.
	Use the default decimal and thousand separators (as set in Windows' Regional settings) or set different separators especially for this Excel file.
	Enable OCR (Optical Character Recognition) if needed. Though this option is selected by default, it deserves special attention if you are converting an image (scanned) PDF document. In this case, make sure there is a tick in the "Run OCR" checkbox and choose the appropriate language by clicking the Set Language button next to it.


When done, click the OK button.






The converted Excel file is very close to the PDF source document. As illustrated in the below screenshot, the document layout as well as formatting was converted almost flawlessly. The only noticeable deficiency is that some of the numbers were exported as text, which is indicated by a small green triangle in the upper-left corner of the cell. You can rectify this deficiency in seconds - simply select all such cells, right-click and choose Format Cells > Number.



For the fairness sake, I used Acrobat Pro XI to convert the same PDF file that was fed to online PDF to Excel converters. The result is very disappointing:



As you in the screenshot above, some numbers that should be associated with the text labels are moved to the top of the sheet, one text entry is lost. But the most critical thing is that all the data was exported to a single column (column A), which considerably complicates further manipulation and data analysis. Even some of the free online PDF converted produced a better result - shame to Adobe!

Advantages: First and foremost - a very quick result and ease of use; for plain tables with a clear structure - neat and accurate conversions with a very little further manipulation required.

Drawbacks: High cost, poor results when converting complex PDF documents.




Converting PDF to Excel with Able2Extract PDF Converter 9

Able2Extract is another big name in the industry, which has been present on the market for over 10 years. Their prices are comparable to Adobe Acrobat Pro and so are the features.

Able2Extract can transfer PDF content into a large variety of formats ranging from Excel, Word, PowerPoint to Publisher and AutoCAD. The Optical Character Recognition (OCR) option is also available.

And now, let's see how this converter will cope with our Gift Planner that has turned out to be a stumbling block for most of online PDF converters as well as for the Adobe software.

To convert your PDF into an editable Excel file, follow these steps:

	Open the PDF document to want to export to Excel. The converter will actually give you a hint where to start.

  
	Select PDF data to convert. This can be the entire document, certain pages, all data on the current page or selected data only. You can make a selection by dragging the mouse pointer, from the Edit menu, or by using the Quick Selection options on the toolbar:

  
	Choose Excel as the conversion format either by clicking the Excel button on the toolbar or select Convert to Excel from the Edit menu. Once you do this, you will be given a choice of Automatic and Custom conversion options.

  
  


I choose Automatic since I want a quick result. If you want to designate how your table will look like in Excel, you can go with Custom. When you click the Define button under Custom, a new pane will appear from which you can start adjusting your tables and the changes will be immediately reflected in the preview section.



What you see below in the result of automatic conversion, which is far superior to what Adobe Acrobat XI Pro produced!



If you want to give Able2Extract a try, you can download an evaluation version here or probably check their prices first :)

Advantages: Quick and accurate PDF to Excel conversions; original colors, formatting and fonts preserved; ability to customize the document prior to conversion; OCR capabilities for scanned PDFs.

Drawback: Expensive.





Converting an image (scanned) PDF to Excel

As noted in the beginning of this article, there is more than one way to create a PDF file. If your PDF was made by using a scanner, or a similar device that takes a "snap-shot" of the document and then stores that image as an electronic PDF file, special Optical Character Recognition (OCR) software is required. An OCR program electronically identifies each character in a scanned document and converts it into an editable format of your choosing, e.g. Microsoft Excel.

The quality of the output document depends on many factors such a good or poor image quality of the source PDF document, clarity of all characters, foreign languages or special symbols used in the text, a mixture of fonts, colors and formats, etc.

Since the optical character recognition that turns an image into an electronic character-based file is a rather complicated process, most of OCR programs are paid. However, there also exist a few free online services that can help you export an "image" PDF document into Excel.


Free online OCR service to convert PDF to Excel

The Optical Character Recognition service available at www.onlineocr.net supports 46 languages including English, French, Chinese, Japanese, Korean and many others. Apart from PDF, it also lets you extract text from JPG, BMP, TIFF and GIF images and convert them into Excel (.xlxs), Word (.docx) or plain text (.txt) files. The maximum allowed file size is 5 MB.



I've tested this service on a few scanned PDF documents in different languages and, frankly, was impressed with the results. Though the original format of the PDF files was lost, most of the text and numerical data was recognized and imported into Excel correctly.

If you want something more than a free OCR service, you may consider trying one of the paid PDF to Excel OCR converters such as PDF2XL OCR or VeryPDF.

And naturally, if you have a license of Adobe Acrobat XI Pro, you won't need any other tools or services, simply utilize the "Run OCR if needed" option, as demonstrated in Exporting PDF to Excel using Adobe Acrobat.




Hopefully, this article has helped you choose the method or tool for your PDF to Excel conversions best suited for your needs and the type of data to be imported. If you are looking for the opposite, you may find the solution in this post - Exporting Excel files to PDF. Thank you for reading!


You may also be interested in

	How to convert text to number in Excel
	How to track changes in Excel
	How to recover unsaved Excel file, use Excel autosave/autorecover features
	How to convert PDF to Word - with online converters or manually
	How to convert Word to PDF - online and desktop solutions
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				Excellor says: 
2024-02-08 at 3:08 pm


What about the built-in convertor? Seems to work fine as well (for what I'm using it). 

It's at Data->Import data->from file->from PDF;

I guess it's just not taking over styles/formatting.
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				Joe says: 
2024-01-19 at 3:10 am


Hello, 

Thanks for this great blog and the complete list of online and offline converters, and I am amazed that unlike other bloggers, you do test those apps in person. Giving that, I think I should recommend a better one pdfocr dot org) to you that I use daily myself, I have made many comparisons against a lot of online converters like onlineocr dot net etc and pdfocr dot org excels every time. I think you definitely should test and review it. You will love it and your users would benefit it from it as well. 

Joe
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2024-01-16 at 6:16 am


There's a PDF import tool that works perfectly, minimal steps, in in Data Ribbon... Get Data,,, from File... from PDF!!!!!!!!!!!
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				Pat Stoops says: 
2020-06-18 at 9:23 pm


Svetlana, do you know if Online OCR has synthetic OCR? I've been looking on a lot of places, including their web site, and haven't found anything referencing it (also called multi-pass ocr). I have found other software that include this feature now (https://www.bisok.com/grooper-data-capture-method-features/multi-pass-ocr/ ) but not that one in particular. My department is looking at several solutions to capture AP documents and wanted to pick your brain. Thank you for your help
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2020-04-20 at 6:26 pm


After converting a PDF of parts with pictures, the pictures are not in line with the part - how can I get those pictures to stay where I place them?
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				Alexander Trifuntov (Ablebits Team) says: 
2020-04-21 at 12:14 pm


Hello Ms. Jefferi!

You may find it useful to have an article on our blog on how to insert pictures in Excel

I hope this will help, otherwise please do not hesitate to contact me anytime.
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2019-08-26 at 10:42 am


Please send file on may mail id.
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2017-06-24 at 6:00 am


I have found the converter of PDF to Excel but the problem is while converting it s not capturing the diagrams only converting the test format. Tell me how to convert the diagram also
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				atif says: 
2021-03-24 at 7:26 am


No Way
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				Jon says: 
2016-03-23 at 10:57 am


worth trying Zanran's new cloud converter:  pdf.zanran.com

It's like the ones you mention above - it emails back the results.  But it seems better than others I've tried.
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				Md Kamil says: 
2015-06-29 at 7:24 am


Thanks for sharing this quick solution for converting pdf file.
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2014-12-08 at 3:39 am


Sounded like a fantastic tip. Thanks for sharing this quick solution for converting pdf file.
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 your query. We cannot guarantee that we will answer every question, but we'll do our best :)
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